home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / linux-wlan-ng-modules-0.2.3 / linux-wlan-ng-modules-0.2.3.ebuild < prev    next >
Text File  |  2006-05-11  |  3KB  |  121 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /root/portage/net-wireless/linux-wlan-ng-modules/linux-wlan-ng-modules-0.2.3.ebuild,v 1.1.1.2 2006/03/22 23:00:25 grimmlin Exp $
  4.  
  5. inherit eutils linux-mod
  6.  
  7. MY_PN=${PN/-modules/}
  8. MY_P=${MY_PN}-${PV}
  9. S=${WORKDIR}/${MY_P}
  10.  
  11. DESCRIPTION="Kernel modules for Prism2/2.5/3 based 802.11b wireless LAN products with injection patch"
  12. HOMEPAGE="http://linux-wlan.org"
  13. SRC_URI="ftp://ftp.linux-wlan.org/pub/linux-wlan-ng/${MY_P}.tar.bz2"
  14.  
  15. LICENSE="|| ( GPL-2 MPL-1.1 )"
  16. SLOT="0"
  17. KEYWORDS="~amd64 ~ppc ~x86"
  18.  
  19. IUSE="debug pci pcmcia plx usb"
  20.  
  21. BUILD_TARGETS="default"
  22. BUILD_PARAMS="WLAN_SRC=${S}/src"
  23.  
  24. show_deprecated_message() {
  25.     if use pci || use plx || use pcmcia; then
  26.         einfo ""
  27.         einfo "You really should try other alternatives for prism support."
  28.         einfo "For example the hostap-driver or orinoco drivers should work"
  29.         einfo "with your wireless card. Support for pci, plx and pcmcia drivers"
  30.         einfo "will most likely be removed in the near future. If the alternatives"
  31.         einfo "don't work for you, please report this to betelgeuse@gentoo.org."
  32.         einfo ""
  33.     fi
  34. }
  35.  
  36. pkg_setup() {
  37.     # We have to put this to the global scope inside the function or it will be
  38.     # reset between functions because the ebuild is sourced many times.
  39.  
  40.     MODULE_NAMES="p80211(net/wireless:${S}/src/p80211)"
  41.  
  42.     if use pci; then
  43.         MODULE_NAMES="${MODULE_NAMES} prism2_pci(net/wireless:${S}/src/prism2/driver)"
  44.     fi
  45.  
  46.     if use plx; then
  47.         MODULE_NAMES="${MODULE_NAMES} prism2_plx(net/wireless:${S}/src/prism2/driver)"
  48.     fi
  49.  
  50.     if use pcmcia; then
  51.         MODULE_NAMES="${MODULE_NAMES} prism2_cs(net/wireless:${S}/src/prism2/driver)"
  52.     fi
  53.  
  54.     if use usb; then
  55.         MODULE_NAMES="${MODULE_NAMES} prism2_usb(net/wireless:${S}/src/prism2/driver)"
  56.     fi
  57.  
  58.     show_deprecated_message
  59.     linux-mod_pkg_setup
  60. }
  61.  
  62. config_by_usevar() {
  63.     local config=${3}
  64.     [[ -z ${config} ]] && config=${S}/default.config
  65.  
  66.     if use ${2}; then
  67.         echo "${1}=y" >> ${config}
  68.     else
  69.         echo "${1}=n" >> ${config}
  70.     fi
  71. }
  72.  
  73. src_unpack() {
  74.     local config=${S}/default.config
  75.  
  76.     unpack ${A}
  77.  
  78.     cd ${S}
  79.     epatch ${FILESDIR}/${MY_P}-module_param.patch
  80.     epatch ${FILESDIR}/${MY_P}-kernel-2.6.16.patch
  81.     epatch ${FILESDIR}/linux-wlan-0.2.3.packet.injection.patch
  82.  
  83.     cp ${S}/config.in ${config}
  84.  
  85.     echo "TARGET_ROOT_ON_HOST=${D}" >> ${config}
  86.     echo "LINUX_SRC=${KERNEL_DIR}"  >> ${config}
  87.     echo "FIRMWARE_DIR=/lib/firmware/" >> ${config}
  88.  
  89.     if use pcmcia && [[ -n "${PCMCIA_VERSION}" ]]; then
  90.         echo "PCMCIA_SRC=${PCMCIA_SOURCE_DIR}" >> ${config}
  91.     fi
  92.  
  93.     config_by_usevar PRISM2_USB usb
  94.     config_by_usevar PRISM2_PCI pci
  95.     config_by_usevar PRISM2_PLX plx
  96.     config_by_usevar PRISM2_PCMCIA pcmcia
  97.     config_by_usevar WLAN_DEBUG debug
  98.  
  99.     if kernel_is gt 2 4; then
  100.         echo "KERN_25=y" >> ${config}
  101.     fi
  102.  
  103.     sed -i -e "s:dep modules:modules:" ${S}/src/p80211/Makefile
  104. }
  105.  
  106. src_compile() {
  107.     set_arch_to_kernel
  108.     emake default_config || die "emake default_config failed"
  109.     set_arch_to_portage
  110.  
  111.     cd ${S}/src/mkmeta
  112.     emake || die "emake mkmeta failed"
  113.  
  114.     linux-mod_src_compile
  115. }
  116.  
  117. pkg_postinst() {
  118.     linux-mod_pkg_postinst
  119.     show_deprecated_message
  120. }
  121.